Results 1 to 5 of 5
  1. #1
    Heroes WoW Member Literate's Avatar
    Join Date
    May 2018
    Posts
    2

    Hi! I'm new, and weird question!

    Hello there, I just started doing private servers again after a longggg time. So I'm trying this one out!

    I am having an issue, not the biggest of one, but I noticed whenever I start the server through the downloaded launcher, my computer completely slows down and chugs while it loads up. I'll be talking on Discord and my voice chat becomes robotic and distorted, and it takes a while to load. I can start any other game instantly with no problem, it only seems to happen with the private server download.

    I googled a few issues and tried disabling things like XBox background recording thing, and all that. I don't know if it's Windows 10 or not.

    Anyone have this issue or know what may be causing it?

  2. #2
    Game Master cheddar's Avatar
    Join Date
    Dec 2016
    Posts
    325
    It would seem your WoW might have a corrupted file in which case the best option is to download the full WoW client with the 2.0 patch already installed found here: https://heroes-wow.com/index.php?page=downloads

    When that is downloaded, proceed to download the Item enchant Patch 2.1 (from the same link) and extract it then place it into your WoW data folder.

    90% of the time re-downloading tends to fix a lot of issues like that. Best of luck and hope it works out that you don't have any more issues after that.
    “Silence is deep as Eternity, speech is shallow as Time.”

  3. #3
    Heroes WoW Member Literate's Avatar
    Join Date
    May 2018
    Posts
    2
    Appreciate the response! Redownloading it still seems to cause the same thing. I downloaded another servers version too, for testing purposes, and it does the same thing. I have two friends who downloaded heroes-wow and they're fine too. So it's something on my end that I can't quite figure out. All I know is I have windows 10 and they do not.

    Hmm, hard to google this issue too :P

  4. #4
    Game Master cheddar's Avatar
    Join Date
    Dec 2016
    Posts
    325
    Unfortunately I don't use win 10 due to all the various issues people seem to have with it. That being said the only thing I can think of is run task manager to see what is being used heavily more than the usual stuff when you run WoW. It could be some update causing issues or something else pulling heavy usage which is slowing everything else down for you from what you described in your first post, then end that process to see if anything changes depending if you can find it or not.

    Considering the most common issue after a re-download not working is that xbox game dvr needing to be disabled which you stated already you did that.
    “Silence is deep as Eternity, speech is shallow as Time.”

  5. #5
    Welcome to the server!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •